From the blog.

Managing Digital Racket
The more I tune out, the less I miss it. But that has presented me with some complex choices for a nuanced approach to curb
Complexity – My Friend, My Enemy
Over my years of network engineering, I've learned that the fewer features you can implement while still achieving a business goal, the better. Why? Fewer

PPP Over Frame with “no peer neighbor-route”

793 Words. Plan about 4 minute(s) to read this.

I am working on Narbik Kocharians’ advanced technology lab workbooks, and had one of those “duh” moments. That moment relates to a fundamental working of PPP. When a PPP circuit comes up, you get a /32 of the opposite side auto-installed into the routing table. I saw that behavior in a lab I’m working on tonight, and believe it or not, I simply did not know about it before. If you want, you can disable that behavior with “no peer neighbor-route” on the PPP interface.

Take a peek at some code. Here, we’ve got 4 routers, R1 – R4. R1 is the hub, the others are spokes. To keep the code print out terse, I’ll just show you R1 & R2. R3 & R4 look the same as R2. On R1, we’ve disabled the remote /32 installation with “no peer neighbor-route“. On R2, we’ve kept the default “peer neighbor-route” in place (not showing because it’s a default command).

R1#show run interf s1/0
!
interface Serial1/0
no ip address
encapsulation frame-relay
frame-relay interface-dlci 102 ppp Virtual-Template1
frame-relay interface-dlci 103 ppp Virtual-Template1
frame-relay interface-dlci 104 ppp Virtual-Template1
end

R1#sho run inter virtual-tem1
!
interface Virtual-Template1
ip address 150.1.100.1 255.255.255.0
no peer neighbor-route
end

R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

150.1.0.0/24 is subnetted, 1 subnets
C 150.1.100.0 is directly connected, Virtual-Access2
is directly connected, Virtual-Access3
is directly connected, Virtual-Access1

! Notice there is no host route from R2…

R1#

R2#show run interf s1/0
!
interface Serial1/0
no ip address
encapsulation frame-relay
frame-relay interface-dlci 201 ppp Virtual-Template2
end

R2#show run interf virtual-tem2
!
interface Virtual-Template2
ip address 150.1.100.2 255.255.255.0
end

R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

150.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 150.1.100.1/32 is directly connected, Virtual-Access1 !<==Notice the host route from R1…
C 150.1.100.0/24 is directly connected, Virtual-Access1

The host route will be installed, even if the remote IP addresses is not in a common subnet. I’m going to reconfigure R1’s IP address and bounce the circuit…watch what happens. R2 will get a new host route.

R1(config)#interf virtual-temp1
R1(config-if)#ip address 1.1.1.1 255.255.255.0 !<==Here’s where I change the IP address.
R1(config-if)#exi
R1(config)#interf s1/0
R1(config-if)#shut
*Feb 29 00:19:15.225: %LINK-5-CHANGED: Interface Serial1/0, changed state to administratively down
*Feb 29 00:19:15.229: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Feb 29 00:19:16.225: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down
*Feb 29 00:19:16.229: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to
down
R1(config-if)#no shut
*Feb 29 00:19:23.845: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
*Feb 29 00:19:23.849: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Feb 29 00:19:23.865: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Feb 29 00:19:24.845: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
*Feb 29 00:19:33.857: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
R1(config-if)#

R2#
*Feb 29 00:18:31.949: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Feb 29 00:18:32.949: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down
*Feb 29 00:18:53.797: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
*Feb 29 00:18:51.949: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Virtual-Access1
150.1.0.0/24 is subnetted, 1 subnets
C 150.1.100.0 is directly connected, Virtual-Access1
R2#