From the blog.

Managing Digital Racket
The more I tune out, the less I miss it. But that has presented me with some complex choices for a nuanced approach to curb
Complexity – My Friend, My Enemy
Over my years of network engineering, I've learned that the fewer features you can implement while still achieving a business goal, the better. Why? Fewer

NMC DOiT Vol.2 Scenario 18 – OSPF Point-To-Multipoint + OSPF Priorities + RIP timers-basic + EIGRP stub receive-only + EIGRP Route Filtering By Source Protocol

956 Words. Plan about 5 minute(s) to read this.

Better late than never, here are my tech notes on NetMasterClass.com DOiT Vol.2 CCIE practice lab scenario 18.

  • When the OSPF network-type is “point-to-multipoint”, /32 routes of the router interfaces involved in that network are advertised. This is because a full-mesh is NOT assumed by OSPF point-to-multipoint. This can be useful in a number of frame-relay connectivity challenges, where one spoke may only be able to communicate to another spoke via the hub. Consider this situation of R1, R2, and R4, all participants in the multipoint frame-relay network 151.10.124.0/24, where R1 is the hub, and R2 and R4 are spokes. Take a look at the /32 routes in the routing table that are auto-generated because this is an OSPF point-to-multipoint network.

    R1#show run interface s1/0.124
    Building configuration…

    Current configuration : 580 bytes
    !
    interface Serial1/0.124 multipoint
    ip address 151.10.124.1 255.255.255.0
    ip ospf network point-to-multipoint
    ip ospf priority 10
    end

    R1#show ip route 151.10.124.0 255.255.255.0 longer-prefixes
    Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2
    i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
    ia – IS-IS inter area, * – candidate default, U – per-user static route
    o – ODR, P – periodic downloaded static route

    Gateway of last resort is not set

    151.10.0.0/16 is variably subnetted, 19 subnets, 3 masks
    C 151.10.124.0/24 is directly connected, Serial1/0.124
    O 151.10.124.2/32 [110/1562] via 151.10.124.2, 6d03h, Serial1/0.124
    O 151.10.124.4/32 [110/1562] via 151.10.124.4, 6d03h, Serial1/0.124
    R1#

    R2#show run interf s1/0.124
    Building configuration…

    Current configuration : 475 bytes
    !
    interface Serial1/0.124 multipoint
    ip address 151.10.124.2 255.255.255.0
    ip ospf network point-to-multipoint
    end

    R2#show ip route 151.10.124.0 255.255.255.0 longer-prefixes
    Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2
    i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
    ia – IS-IS inter area, * – candidate default, U – per-user static route
    o – ODR, P – periodic downloaded static route

    Gateway of last resort is not set

    151.10.0.0/16 is variably subnetted, 22 subnets, 3 masks
    O 151.10.124.1/32 [110/1562] via 151.10.124.1, 6d03h, Serial1/0.124
    C 151.10.124.0/24 is directly connected, Serial1/0.124
    O 151.10.124.4/32 [110/3124] via 151.10.124.1, 6d03h, Serial1/0.124

    R2#

    R4#show run interface s0/0.124
    Building configuration…

    Current configuration : 202 bytes
    !
    interface Serial0/0.124 multipoint
    ip address 151.10.124.4 255.255.255.0
    ip ospf network point-to-multipoint
    end

    R4#show ip route 151.10.124.0 255.255.255.0 longer-prefixes
    Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2
    i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
    ia – IS-IS inter area, * – candidate default, U – per-user static route
    o – ODR, P – periodic downloaded static route

    Gateway of last resort is not set

    151.10.0.0/16 is variably subnetted, 19 subnets, 3 masks
    O 151.10.124.1/32 [110/64] via 151.10.124.1, 6d03h, Serial0/0.124
    C 151.10.124.0/24 is directly connected, Serial0/0.124
    O 151.10.124.2/32 [110/1626] via 151.10.124.1, 6d03h, Serial0/0.124

    R4#

  • Let’s say you have been asked to make R1 the most preferred OSPF DR and R2 the most preferred BDR. You are being asked to set priorities, and you probably knew that. Here’s the catch: I set R1 to be OSPF priority 10, and R2 to be OSPF priority 5. Other routers on the segment were set to OSPF priority 0. R1 was elected the DR, and R2 the BDR, as expected. But this was the wrong answer. R2’s priority must be R1’s priority minus 1, to meet the requirement of “most preferred” BDR. Ergo, if I set R1 to OSPF priority 10, I should have set R2 to be OSPF priority 9.
  • If you are told to advertise a specific route into OSPF, but that you can’t use a network statement, interface ospf statement, or redistribute connected, then they probably want you to redistribute that route from another protocol.
  • The RIP “timers basic” command allows you to adjust RIP update, invalid, hold, and flush timers. This is configured in the “router rip” paragraph, not on the interface level. However, IOS may automatically install an “ip rip advertise” statement on the interface for you, depending on IOS version. Oddly enough, I can’t find a reference to this command anywhere in the cisco.com documentation, not even in the 12.4 IOS master command index. A search of cisco.com comes up dry as well. Huh. Whaddya know about that…
  • To make an EIGRP router quiet (i.e. not advertise any routes, but still be an adjacent neighbor), configure the router you want to keep quiet with “eigrp stub receive-only“. All the receive-only stub router will do is listen to updates from his neighbor.
  • It is possible to filter routes out of EIGRP based on the source protocol of the route in question. Check out this IOS code, where the router is going to filter inbound routes learned on Fa0/0.16 in a couple of ways. (1) He’s going to drop any routes that were originally “connected” routes via the “match source-protocol” statement (found, oddly enough, under the BGP command list). (2) He’s going to drop any routes matching the prefix-list “IN->EIGRP”. All other routes will be allowed.

    router eigrp 100
    distribute-list route-map IN->EIGRP in FastEthernet0/0.16
    !
    ip prefix-list IN->EIGRP seq 5 permit 140.10.2.0/24
    !
    route-map IN->EIGRP deny 10
    match source-protocol connected
    !
    route-map IN->EIGRP deny 20
    match ip address prefix-list IN->EIGRP
    !
    route-map IN->EIGRP permit 30

More in the next post…