From the blog.

Managing Digital Racket
The more I tune out, the less I miss it. But that has presented me with some complex choices for a nuanced approach to curb
Complexity – My Friend, My Enemy
Over my years of network engineering, I've learned that the fewer features you can implement while still achieving a business goal, the better. Why? Fewer

NMC DOiT Vol.2 Scenario 7 Day 4-3 – SNMP Remote Reload + Buffers + The Mighty Power of Fair-Queue

409 Words. Plan about 2 minute(s) to read this.

Other miscellany picked up from scenario 7…

The snmp-server system-shutdown command will allow the router to be reloaded via a remote SNMP set command, assuming the proper SNMP credentials, of course.

The buffers command allows you to modify system buffer pools, useful for process-switched packets.

Just because the lab stated that you can’t use a NUMBERED access list, that doesn’t necessarily mean that you can’t use an access list at all. You may well be able to use a NAMED access list instead. So read carefully. An easy task had me flustered, because I incorrectly assumed you couldn’t use an ACL at all.

Some complicated-sounding tasks aren’t always as challenging as they sound. For example, I was instructed to configure weighted fair-queueing on both sides of a frame connection, and then set the congestive discard threshold to 128 messages, dynamic queues to 512 and RSVP queues to 10. I have a long way to go to get as smart as I need to be about QoS, and this task sounded a little intimidating. I was imagining having to write class-maps and apply a policy to the interfaces (CBWFQ), or use some commands that were new to me. I was partially right – I did need to use a command, the parameters of which were new to me. This was simply flow-based weighted fair queuing, not class-based, so that intimidating-sounding task list is handled by the single interface-level command “fair-queue”.

R5#show run interf s1/0

Building configuration…
Current configuration : 335 bytes
!
interface Serial1/0
ip address 172.16.25.5 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
clock rate 128000
frame-relay map ip 172.16.25.2 500 broadcast
frame-relay map ip 172.16.25.5 500
frame-relay interface-dlci 500
no frame-relay inverse-arp
frame-relay intf-type dce
end

R5#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R5(config)#interf s1/0
R5(config-if)#fair-queue ?
<1-4096> Congestive Discard Threshold
<cr>

R5(config-if)#fair-queue 128 ?
<16-4096> Number Dynamic Conversation Queues
<cr>

R5(config-if)#fair-queue 128 512 ?
<0-1000> Number Reservable Conversation Queues
<cr>

R5(config-if)#fair-queue 128 512 10
R5(config-if)#^Z
R5#show run interf s1/0
*May 3 11:09:55.679: %SYS-5-CONFIG_I: Configured from console by console
Building configuration…

Current configuration : 335 bytes
!
interface Serial1/0
ip address 172.16.25.5 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
fair-queue 128 512 10
clock rate 128000
frame-relay map ip 172.16.25.2 500 broadcast
frame-relay map ip 172.16.25.5 500
frame-relay interface-dlci 500
no frame-relay inverse-arp
frame-relay intf-type dce
end

R5#show queueing fair | i Inter|thres|Serial1/0
Interface Discard Dynamic Reserved Link Priority
threshold queues queues queues queues
Serial1/0 128 512 10 8 1

R5#

Another weighted fair queueing configuration example.